Label printing in Koha

In 3AMK libraries, we are using special printers for printing spine labels. Our printer models are Datamax E-4203, Datamax E-4204, Attune Delta A2 and T
SC TA310.

The label sizes are 38mm x 25mm (Haaga-Helia, Laurea) and 36mm x 23mm (Metropolia)

We are printing labels using browsers Firefox ESR and/or Google Chrome. Notice! Documentation has slightly old screenshots from an older Firefox
version. I'll update this soon! (24.1.2024 Johanna).

Here's our documentation (pdf) about printing in Koha using Label Maker plugin (document is in Finnish "Selkatarratulostus Kohassa Datamax- ja Attune-
kirjoittimille™) >
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Steps to consider when printing labels, e.g. spine labels

® Steps to consider when printing labels, e.g. spine labels
© 1. Need for different layouts
© 2. How to get labels libraries need?
® Option 1. Koha's Tools > Catalog: Quick spine label creator
" Option 2. Koha's Tools > Catalog: Label creator
" Option 3. Koha-Suomi's Visual Label tool plugin
= Option 4. Label Maker plugin by ByWater Solutions
Template for Finn-ID 38mm x 25mm (Itemcallnumber, Padsana kokonaan)
Template for Finn-ID 38mm x 25mm (itemcallnumber, Péasana 3-kirjaiminen)
Layout for Finn-ID 38mm x 25mm (Arial 12)
Layout for Finn-ID KAPEAMPI 36mm x 23mm (Arial 12)
Layout for Finn-ID 38mm x 25mm (Arial 16)
® Printer profiles
© 3. How to print labels using Koha's Label creator and Label Maker plugin (after all printer settings, templates and layouts are set)
© 4. Managing label batches
© Helpful links when modifying layouts

1. Need for different layouts


https://www.kiwi.fi/download/attachments/173867853/Selk%C3%A4tarratulostus_KVKohat_301120.pdf?version=1&modificationDate=1606762318810&api=v2
https://www.kiwi.fi/download/attachments/173867853/Selk%C3%A4tarratulostus_KVKohat_301120.pdf?version=1&modificationDate=1606762318810&api=v2

Label 1. All information is taken from itemcallnumber

o - Full call number |Ug1 VEAL

p - Barcode | 1357129557

The label should look like this.

On the first line there is shelf number
On the second line main word (VEAL) is printed.
- The challenge: If the main word is long, it is splitted to the third/fourth line.

Label 2. All information is taken from itemcallnumber

o - Full call number | 65.012.4 PILLOT DE CHENECEY
p - Barcode (1357146611

The label should look like this.

On the first line there is shelf number. BTW, the longest shelf number is 658.8.012.1 (at Pasila campus).
One the second line, main word (PILLOT DE CHENECEY) is cropped to 3 characters (PIL).

2. How to get labels libraries need?



Option 1. Koha's Tools > Catalog: Quick spine label creator

® Suitable for libraries which use only one-type of label

Option 2. Koha's Tools > Catalog: Label creator
https://koha-kktest.lib.helsinki.fi/cgi-bin/koha/labels/label-home.pl

To test this, one can create a template and a label layout (e.g. name both as Finn-ID 38mm x 25mm), and printer profile (Datamax/Attune) on Koha test
server.

® | managed to print labels for Haaga campus. So this method works in some libraries!
® |f you need labels where call number is splitted to the second line and to 3-letters/characters, use option 4.

Option 3. Koha-Suomi's Visual Label tool plugin

Plugin has been developed during spring 2022 by Koha-Suomi to work with Koha's Community version.
Documentation and download from https://github.com/KohaSuomi/koha-plugin-visual-label-tool

® Haven't tested this yet in 3AMK (25.1.2024 Johanna)

Option 4. Label Maker plugin by ByWater Solutions

1. Label Creator plugin blog and video instructions:
a. Part 1: https://bywatersolutions.com/education/label-creator-plugin
b. Part 1, video: Label Maker Koha Plugin Part 1
c. Part 2: https://bywatersolutions.com/education/using-the-label-plugin-in-koha-part-2
d. Part 2, video: Label Maker Plugin Koha Part 2
2. Github: https://github.com/bywatersolutions/koha-plugin-label-maker
a. KPZ-file: https://github.com/bywatersolutions/koha-plugin-label-maker/releases

The plugin is installed in Koha test server, and can be used:
https://koha-kktest.lib.helsinki.fi/cgi-bin/koha/plugins/plugins-home.pl

® In your own Koha, go to Administrator > Manage plugins > Plugins
® |nstall latest KPZ-file from Github

Notice! 0.0.7 and newer plugins creates an extra, empty label.

E.g. if in your batch there are 2 or more labels, printing creates 3 labels (last one is empty). Not good, so it has to be investigated,
why this happens.

There is no such problem with version 0.0.6 (3AMK). Same template and layouts are used in both versions. Maybe template/layout
code needs tweaking?
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Label Maker [EZEE=) An alternative label creator for Koha powered by HTML and CSS Kyle M Hall 0.0.6 17.05.00.000 121972018 || actions «

® Click button Actions > Run tool

® Plugin can also be found via Tools > Tool plugins > Label Maker

® Default templates are: Avery Standard Labels and Basix 55-459-007 (do not delete those)

L]

Copy additional templates and layouts from here, or from Koha3 test server, for Datamax and Attune printers (do not delete, copy if you want to
create your own templates):

Template for Finn-ID 38mm x 25mm (Itemcallnumber, Padsana kokonaan)

[% FOREACH item IN items %

[%IF loop.index %1 == 0 %
[% SET | abel _index = 1 %
[ % UNLESS | oop.first %

</ span>

[ % END %
<span cl ass="page">

[ % END %

<div class="I|abel |abel[% abel _index %4">
[%itemitencal | nunber.replace(' "(\S+H)\s+(\S+).*', '$1<br>$2') %
</ di v>
[%I1F | oop.last % </span>[ % END %
[% SET | abel _index = | abel _index + 1 %
[ % END %

Template for Finn-ID 38mm x 25mm (itemcallnumber, Pdasana 3-kirjaiminen)



https://koha-kktest.lib.helsinki.fi/cgi-bin/koha/labels/label-home.pl
https://github.com/KohaSuomi/koha-plugin-visual-label-tool
https://bywatersolutions.com/education/label-creator-plugin
https://youtu.be/-hL7iR8MmTQ
https://bywatersolutions.com/education/using-the-label-plugin-in-koha-part-2
https://youtu.be/Rz5r91fG174
https://github.com/bywatersolutions/koha-plugin-label-maker
https://github.com/bywatersolutions/koha-plugin-label-maker/releases
https://koha-kktest.lib.helsinki.fi/cgi-bin/koha/plugins/plugins-home.pl

[% FOREACH item IN itens %

[%IF loop.index %1 == 0 %
[% SET | abel _index = 1 %
[ % UNLESS | oop.first %

</ span>

[ % END %
<span cl ass="page">

[ % END %

<div class="I|abel |abel[% abel _index %4">
[%itemitencal | nunber.replace(' *(\S+H)\s+(\S{0,3}).*", '$1<br>%$2') %
</ di v>
[% I F | oop.last % </span>[ % END %
[% SET | abel _index = | abel _index + 1 %
[ % END %

Layout for Finn-ID 38mm x 25mm (Arial 12)
® Basic layout that you can easily modify for your own purposes

® padding-top: 3-6mm (In Haaga-Helia, we use value 3mm here)
® margin-left; 5-6mm (In Haaga-Helia, we use value 6mm here)

htm, body, div, span, hl {

margin: O;
paddi ng: 1;
border: O;
}
body {

width: 43mm /* Wdth of |abel page */
hei ght: 30nm /* Height of |abel page */
font-famly: Arial;

}

- page {
paddi ng-top: 6mm /* Height fromtop of page to top of first |abel row */
margin-left: 6mm /* Wdth of gap fromleft of page to left edge of first |abel colum */

page- break-after: al ways;
clear: left;
di spl ay: bl ock;

abel {

width: 38mm /* Wdth of actual |abel */

hei ght: 25nm /* Height of actual |abel */

margin-right: Oin; /* Distance between each colum of |abels */

float: left;

text-align: left;
font -wei ght: bol d;
font-size: 12px;

overflow hidden;

/* Uncomrent for testing and debuggi ng */
/* outline: 1lpx dotted; */
}

. page-break {
clear: left;
di splay: bl ock;
page- break-after: al ways;

Layout for Finn-ID KAPEAMPI 36mm x 23mm (Arial 12)



htm, body, div, span, hl {
margi n: O;
paddi ng: 1;
border: O;

body {
width: 38mm /* Wdth of |abel page */
hei ght: 28nm /* Height of |abel page */
font-famly: Arial;

}

. page {
paddi ng-top: 6mm /* Height fromtop of page to top of first |abel row */
margin-left: 5mm /* Wdth of gap fromleft of page to left edge of first |abel colum */

page- break-after: al ways;
clear: left;
di splay: bl ock;

.l abel {
width: 36mm /* Wdth of actual |abel */
hei ght: 23mm /* Height of actual |abel */
margin-right: 0in; /* Distance between each colum of |abels */

float: left;

text-align: left;
font -wei ght: bol d;
font-size: 12px;
overflow hidden;

/* Unconmment for testing and debuggi ng */
/* outline: 1lpx dotted; */

}

. page-break {
clear: left;
di spl ay: bl ock;
page- break-after: al ways;

Layout for Finn-ID 38mm x 25mm (Arial 16)



htm, body, div, span, hl {

margi n: O;

paddi ng: 1;

border: O;
body {

width: 43mm /* Wdth of |abel page */
hei ght: 30nm /* Height of |abel page */
font-famly: Arial;

}

. page {
paddi ng-top: 2mm /* Height fromtop of page to top of first |abel row */
margin-left: 8nm /* Wdth of gap fromleft of page to left edge of first |abel colum */

page- break-after: al ways;
clear: left;
di splay: bl ock;

.l abel {
width: 38mm /* Wdth of actual |abel */
hei ght: 25mm /* Hei ght of actual |abel */
margin-right: 0in; /* Distance between each colum of |abels */

float: left;

text-align: left;
font -wei ght: bol d;
font-size: 16px;
overflow hidden;

/* Unconmment for testing and debuggi ng */
/* outline: 1lpx dotted; */

}

. page-break {
clear: left;
di spl ay: bl ock;
page- break-after: al ways;

® On KohaTest server (kktest), there are batches with several items, and you can use those to test printing.

Printer profiles

® There are no examples on how to set Printer profiles. Not needed at 3AMK libraries. / 25.1.2024 Johanna

3. How to print labels using Koha's Label creator and Label Maker plugin (after all printer
settings, templates and layouts are set)

. Go to Tools - Tool plugins > Label Maker
. Click New - Label batch
. It will take you Koha's own tool "Label creator". Add barcodes you want to print.
. Go back to Label Maker plugin and click Print labels
a. Select the batch that includes barcodes you want to print to labels (batch number)
b. Select the template
c. Select layout
d. No need to select printer profile (since we don't have one yet, - because we don't know how to create one by coding)
e. Click Print labels

HONP



Home » Plugins » Label Maker » Print labels

Print labels

Batch:

Template: | Finn-ID 38mm x 25mm (Pa&sana 3-kirjaiminen) v |

Layout: | Finn-ID 38mm x 25mm (Arial 12px)

v

Printer profile: | v

Starting label: ‘ 1 ‘

& Print labels  [@E=lel]

5. In Browser preview window (Firefox), select Print from right-side menu

6. Print Setup - Format & Options (landscape, scale 130, %, uncross Shrink to fit Page Width)

7. Print Setup Margins & Header/Footer - 0 margins to all, blank to all

8. Then click Print
9. Choose Microsoft Print to PDF, and create pdf. Save pdf to e.g. Desktop, use separate folder that is easy to locate.

10. Print pdf by choosing the label printer like Datamax, Attune, TSC. Check that Page sizing and Handling you have Actual fit; and orientation is
here Portrait.

See attached document about settings in Datamax and Attune printers >

4. Managing label batches

Label batches can be managed in Koha's own tool (Label creator)

Home > Tools » Label creator > Batches
Delete unnecessary batches.

One easy practice is keep one Batch ID per staff member. But, keep at least one item on the batch. Add new barcodes and delete old ones away.

+ New « (& Manage ~

Currently available batches

Showing 1 to 3 of 3 entries Shuwenlries < Previous Next > Search
Batch ID Description - Item count
1 6
2 7
3 1
Showing 1 ta 3 of 3 entries < Previous Next >

Helpful links when modifying layouts

Conversion of Measurement Units

CSS Tutorial (for padding, margins etc.)
CSS Web Safe Fonts

Font families

X Clear filter
Actions
(# Edit || @ Delete O
(# Edit || @ Delete O
(Z Edit || @ Delete o



https://www.kiwi.fi/download/attachments/173867853/Selk%C3%A4tarratulostus_KVKohat_301120.pdf?version=1&modificationDate=1606762318810&api=v2
https://www.convertunits.com/from/43+mm/to/inches
https://www.w3schools.com/css/default.asp
https://www.w3schools.com/cssref/css_websafe_fonts.asp
https://www.w3.org/Style/Examples/007/fonts.en.html
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